Google reports issues with Calendar API

Incident Report for GoodTime

Resolved

Google has resolved the problem with Google Calendar. For the interviews that failed to create calendar events (red ! in dashboard), please go in and click update on the interview to create the calendar events
Posted Sep 21, 2023 - 10:56 PDT

Monitoring

Google Calendar service has already been restored for some users, and we expect a resolution for all users within the next 1 hour. Please note this time frame is an estimate and may change.

Google rolled back an update, and their engineers are seeing recovery. They are monitoring further for full resolution.

Please refer to the following Google Status Page for more information:
https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 09:10 PDT

Update

Google is continuing to investigate this issue. Google will provide an update by Sep 21, 2023, 4:00 PM UTC detailing when to expect to resolve the problem. As a results, users may experience errors when trying to connect to Google Calendar, create interviews, or check for availability on GoodTime.

Please refer to the following Google Status Page for more information:
https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 08:53 PDT

Update

Google reports that it will provide a status update today at 8:45 https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 08:19 PDT

Identified

Google is currently reporting an incident impacting users of Google Calendar. As a results, users may experience errors when trying to connect to Google Calendar, create interviews, or check for availability on GoodTime.

Please refer to the following Google Status Page for more information:
https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 07:58 PDT

Update

Google continues reporting issues with its Google Calendar API. https://www.google.com/appsstatus/dashboard/incidents/7uJZ5F1Uy4n1n74iMacQ
Posted Sep 21, 2023 - 07:54 PDT

Update

We are continuing to investigate this issue.
Posted Sep 21, 2023 - 07:32 PDT

Investigating

We are experiencing issues with the Google Calendar API. Google is also reporting issues with the Google Calendar app. The team is investigating and we will update you shortly: https://www.google.com/appsstatus/dashboard/
Posted Sep 21, 2023 - 07:31 PDT
This incident affected: Calendar Services (Google Apps Calendar).