Greenhouse sync issues

Incident Report for GoodTime

Resolved

In partnership with Greenhouse, we identified the issue causing API communication slowdowns. Sync performance will gradually return to normal today.
Posted Sep 18, 2023 - 13:31 PDT

Monitoring

Goodtime is monitoring the results.
Posted Sep 18, 2023 - 07:23 PDT

Update

Our present investigations and ongoing optimization have uncovered inconsistencies in Greenhouse rate limit policies that may be prematurely bottlenecking requests. These inconsistencies appear to be the root cause of performance issues for Greenhouse customers users on GoodTime. We're actively working with Greenhouse to resolve this issue.
Posted Sep 17, 2023 - 23:07 PDT

Update

We have narrowed the issue down and will deploy a fix as soon as we have identified it
Posted Sep 16, 2023 - 12:23 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 15, 2023 - 15:30 PDT

Update

We are still working on fixing latency issues in our platform affecting customers who have a GoodTime integration with Greenhouse. This is currently our highest priority.
Thank you for your patience!
Posted Sep 15, 2023 - 07:26 PDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 14, 2023 - 17:26 PDT

Update

Goodtime has deployed a fix to improve the slow performance. However, some lag in the integration with Greenhouse persists
Posted Sep 14, 2023 - 16:20 PDT

Identified

Greenhouse customers are experiencing slow response times due to issues with the Greenhouse API. The issue is caused by Greenhouse ATS maintenance and we are monitoring their progress.
Posted Sep 14, 2023 - 07:31 PDT

Update

We are continuing to investigate this issue.
Posted Sep 14, 2023 - 06:03 PDT

Investigating

Greenhouse customers are currently experiencing slow response times and difficulties opening candidates in Goodtime from the Greenhouse site.
Posted Sep 14, 2023 - 05:59 PDT
This incident affected: Applicant Tracking Systems (Greenhouse) and Goodtime Hire (Dashboard (a.goodtime.io)).