Out of date search results

Incident Report for GoodTime

Identified

Search results are now up to date but with reduced information showing in the search panel. We will continue to work on resolving this issue.
Posted Nov 04, 2025 - 06:23 PST

Investigating

Some users have reported that new candidates are not appearing when using the search bar. We are actively investigating this issue.
Posted Nov 04, 2025 - 06:12 PST
This incident affects: Goodtime Hire (Dashboard).