"This interview doesn't exist" message
Incident Report for GoodTime
Resolved
This incident has been resolved.
Posted Mar 24, 2023 - 15:56 PDT
Investigating
We are currently investigating an issue where some users are seeing a "This interview doesn't exist" error message. This is our top priority at the moment and we will update you as soon as possible.
Posted Mar 24, 2023 - 15:45 PDT
This incident affected: Goodtime Hire (Dashboard (a.goodtime.io)).