Slow response time

Incident Report for GoodTime

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 08:53 PDT

Update

The issue has been identified and mitigated. Response times should return to normal for all customers
Posted Oct 24, 2025 - 08:14 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 24, 2025 - 08:13 PDT

Investigating

Goodtime users may experience degraded performance while using Goodtime Hire. The team is looking the cause.
Posted Oct 24, 2025 - 07:44 PDT
This incident affected: Goodtime Hire (Automation Tab, Superdays, Insights, Dashboard).