Lever experiencing issues in North America
Incident Report for GoodTime
Resolved
This incident has been resolved.
Posted Feb 18, 2025 - 11:45 PST
Monitoring
Lever has indicated that service should be returning to normal. We will continue to monitor. More information on the issue can be found here: https://status.lever.co/incidents/r94mjyqwbxtv
Posted Feb 18, 2025 - 11:03 PST
Identified
Some customers may experience intermittent issues with the Lever integration. More information on the outage can be found here: https://status.lever.co/incidents/r94mjyqwbxtv
Posted Feb 18, 2025 - 07:31 PST
This incident affected: Applicant Tracking Systems (Lever).