Global IT Outage
Incident Report for GoodTime
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 07:33 PDT
Monitoring
Goodtime is aware of the Global IT Outage. We are closely monitoring the situation and will keep you updated
Posted Jul 19, 2024 - 09:07 PDT
This incident affected: Goodtime Hire (Dashboard (a.goodtime.io)).