Some users are seeing a blank page

Incident Report for GoodTime

Resolved

This incident has been resolved.
Posted Feb 05, 2024 - 15:31 PST

Monitoring

If you are experiencing this issue, please clear your cache and refresh.
Posted Feb 05, 2024 - 14:50 PST

Investigating

If you are experiencing this issue, please clear your cache and refresh.
Posted Feb 05, 2024 - 14:47 PST
This incident affected: Goodtime Hire (Dashboard (a.goodtime.io)).