Microsoft reports issues with the Teams product
Incident Report for GoodTime
Resolved
At 5:30 PM Pacific Time, Microsoft Issued an All Clear and issued this comment:
Final status: After extended monitoring and various optimizations and mitigation efforts, we’ve confirmed that our Microsoft Teams service and features have been restored or returned to optimal health.
Posted Jan 26, 2024 - 17:30 PST
Identified
Microsoft is still reporting the issue.
Posted Jan 26, 2024 - 14:46 PST
Investigating
From the Microsoft Status Page: https://portal.office.com/servicestatus

Some users may experience multiple issues with their Microsoft Teams
Posted Jan 26, 2024 - 11:26 PST