Slow downs during scheduling
Incident Report for GoodTime
Postmortem

Dear Customers,

Starting around 8 a.m. PT, we noticed some latency in the GoodTime Hire platform that may have affected your ability to schedule interviews. As of now, we do not see latency issues that may cause issues in the core scheduling capabilities of the product.

Upon further investigation, we discovered that the root cause of this was a penetration test that was being conducted by a 3rd party vendor we hired. As you know, ensuring GoodTime is a secure platform is a top priority for our customers. At the same time, system reliability is also of utmost importance. It is table stakes.

We have since contacted the vendor and are in the process of scheduling the penetration test at a time most convenient for our customers and causing the least disruption to scheduling activities.

We apologize for this and will ensure future security testing of a similar kind is performed during off-peak hours. Please do not hesitate to reach out to me if you have any questions. I can be reached at romeo.leon@goodtime.io.

Sincerely,

Romeo Leon
VP of Customer Success

Posted Oct 18, 2023 - 20:28 PDT

Resolved
This incident has been resolved.
Posted Oct 18, 2023 - 11:42 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 18, 2023 - 08:50 PDT
Investigating
Some customers are reporting slow downs during scheduling.
Posted Oct 18, 2023 - 08:21 PDT
This incident affected: Goodtime Hire (Dashboard (a.goodtime.io)).