Microsoft Outlook is experiencing issues

Incident Report for GoodTime

Resolved

This incident has been resolved.
Posted 4 months ago. Nov 26, 2024 - 08:09 PST

Update

We are continuing to monitor for any further issues.
Posted 4 months ago. Nov 25, 2024 - 10:30 PST

Monitoring

This issue may impact scheduling for customer using O365. We will continue to monitor this situation.
Posted 4 months ago. Nov 25, 2024 - 10:29 PST
This incident affected: Calendar Services (Calendar Sync).